Outils pour utilisateurs

Outils du site


Panneau latéral

sisr2:tp8-dhcpvlan

Serveur DHCP et gestion des VLANs

COURS DE REFERENCE

PRESENTATION

Ce TP va vous permettre (j'espère ! :) ) de comprendre la technique que nous utilisons dans la salle de TP B512 dédiée BTS SIO SISR pour permettre aux étudiants d'accéder indifféremment :

  • au VLAN BTSSIO (VLAN 15)
  • au VLAN Bac à Sable BaS (VLAN 17)

Chaque VLAN possède son propre réseau IP.

Nom VLANNuméro VLANréseau
BTSSIO1510.187.37.0/24
BaS17192.168.238.0/24

PRINCIPE DE FONCTIONNEMENT

Le principe de fonctionnement est simple : il consiste à attribuer certains ports du switch Allied Telesis AT8000S au VLAN 15 (BTSSIO) et d'autres ports au VLAN 17 (BaS). Ces ports sont connectés aux prises murales RJ45 de la salle B512. Donc, en fonction de l'association PORT/N°VLAN, un équipement terminal connecté à une prise murale appartiendra au VLAN 15 ou au VLAN 17 en fonction de la configuration du commutateur.

Inconvénient :

En pratique, lorsque l'on veut basculer un équipement terminal d'un VLAN vers un autre, il faut :

  • soit “brasser du câble” dans l'armoire B512,
  • soit modifier la config. du switch AT8000S.

Ceci n'est guère satisfaisant car ces manipulations sont sources d'erreurs pouvant porter à conséquence sur un switch départemental.

UNE PETITE AMELIORATION !

Pour éviter de brasser du câble ou de modifier la config. du commutateur départemental AT8000S, nous allons connecter sur chaque port du AT8000S, via la prise murale RJ45 associée, un petit switch administrable “de bureau” Netgear GS108T.

Le lien entre les 2 commutateurs sera un lien de type “trunk”.

Sur chaque Netgear GS108T, seront configurés des ports associés au VLAN 15 et des ports associés au VLAN 17. Pour associer un équipement terminal à un VLAN (15 ou 17), il suffit de se connecter sur le port désiré sur NETGEAR GS108T sans intervenir en aucune façon sur AT8000S.

En résumé, ce montage permet de déporter la gestion des VLAN au plus près de l'utilisateur (l'étudiant) qui aura la possibilité de gérer physiquement (par une opération de brassage) ou logiquement (par reconfiguration du switch de bureau) l'association de ses équipements avec tel ou tel VLAN sans intervenir sur le switch départemental (ce qui ne lui est pas autorisé).

CONFIGURATION IP DES EQUIPEMENTS

Un serveur DHCP muni de 2 interfaces :

  • interface 1 sur le réseau 10.187.37.0/24
  • interface 2 sur le réseau 192.168.238.0/24

va distribuer une configuration IP à l'équipement terminal client DHCP en fonction du VLAN sur lequel il se trouve.

SIMULATION PACKET TRACER

La maquette à réaliser

Le routeur sera connecté au switch départemental par une seule interface physique Gigabit G0/0. Il est donc nécessaire de configurer 2 sous-interfaces G0/0.15 et G0/0.17, le débit pratique pour chacune de ces sous-interfaces étant de 500 Mbits/s.

Une solution de “riche” consisterait à utiliser 2 interfaces physiques mais dans ce cas précis, cela serait sans doute du gaspi d'interfaces (une interface physique sur un routeur n'est pas donnée !) et le trafic généré par le service DHCP ne justifie sans doute pas cette solution maximaliste (Tout dépend en fait du nombre de clients DHCP et de la durée de bail).

Interfaces ou sous-interfaces ? Avantages et désavantages.

Vous pouvez utilement aller ici :

ROUTAGE INTER-VLAN

Configuration du routeur-serveur DHCP

1 - Création des sous-interfaces

Sous-interface VLAN 15

Router(config)#int g0/0.15
Router(config-subif)#encapsulation dot1Q 15
Router(config-subif)#ip address 10.187.37.1 255.255.255.0
Router(config-subif)#no shut
Router(config-subif)#exit

Sous-interface VLAN 17

Router(config)#int g0/0.17
Router(config-subif)#encapsulation dot1Q 17
Router(config-subif)#ip address 192.168.238.1 255.255.255.0
Router(config-subif)#no shut
Router(config-subif)#exit

2 - Configuration du service DHCP

Exclusion des adresses IP des interfaces du routeur

Router(config)#ip dhcp excluded-address 192.168.238.1
Router(config)#ip dhcp excluded-address 10.187.37.1

Affectation d'un pool d'adresses IP pour chaque VLAN

VLAN 15

Router(config)#ip dhcp pool vlan15
Router(dhcp-config)#network 10.187.37.0 255.255.255.0
Router(dhcp-config)#default-router 10.187.37.1
Router(dhcp-config)#exit

VLAN 17

Router(config)#ip dhcp pool vlan17
Router(dhcp-config)#network 192.168.238.0 255.255.255.0
Router(dhcp-config)#default-router 192.168.238.1
Router(dhcp-config)#exit

Configuration du switch départemental 2960 (alias AT8000S)

PORT(S)MODE D'ACCESVLANs
G1/1Trunk15 et 17
G1/2Trunk 15 et 17
Fa0/1 à Fa0/6Access15
Fa0/7 à Fa0/12Access17

Affectation des ports Fa0/1 à Fa0/6 au VLAN 15

Switch(config)#interface range fa0/1-6
Switch(config-if-range)#switchport mode access
Switch(config-if-range)#switchport access vlan 15
Switch(config-if-range)#ex

Affectation des ports Fa0/7 à Fa0/12 au VLAN 17

A vous de jouer !! :)

Configuration des ports TRUNK G1/1 et G1/2

Switch(config)#interface gigabitEthernet 1/1
Switch(config-if)#switchport mode trunk

Switch(config)#interface gigabitEthernet 1/2
Switch(config-if)#switchport mode trunk

Tests !

D'ors et déjà, les équipements terminaux, configurés en clients DHCP, doivent récupérer une configuration IP ad hoc en fonction du port de rattachement (et donc du VLAN associé).

Faites les tests nécessaires en déplaçant un équipement d'un port (Fa0/2 par exemple) vers un autre port situé dans l'autre VLAN (Fa0/11 par exemple).

Configuration du switch de bureau 2960 (alias Netgear GS108T)

PORT(S)MODE D'ACCESVLANs
Fa0/8Trunk15 et 17
Fa0/1 à Fa0/3Access15
Fa0/4 à Fa0/7Access17

Affectation des ports Fa0/1 à Fa0/3 au VLAN 15

A vous de jouer !

Affectation des ports Fa0/4 à Fa0/7 au VLAN 17

Your turn !

Configuration du port TRUNK Fa0/8

tienes que jugar !

Tests !!

Les équipements terminaux attachés au Netgear, configurés en clients DHCP, doivent récupérer une configuration IP ad hoc en fonction du port d'attachement (et donc du VLAN associé).

Faites les tests nécessaires en déplaçant un équipement d'un port (Fa0/2 par exemple) vers un autre port situé dans l'autre VLAN (Fa0/7 par exemple).

sisr2/tp8-dhcpvlan.txt · Dernière modification: 2014/01/06 12:03 (modification externe)